Automation getting started

To report errors related to CertCentral agent automation and sensor-based agentless automation., contact our Support team.

Before you get started with CertCentral automation, check these access and system requirements:

  • You’ll need to install and configure CertCentral sensors and agents wherever your SSL/TLS certificates are installed, so as a server admin or IT security specialist, you should be comfortable with managing servers, webhosts, load balancers, and similar devices.
  • Admin or root access is required to the device that hosts the certificate you want to automate.
  • CertCentral automation is supported on:

ACME agent automation for dedicated web servers

Operating system Operating system version Applications
Linux CentOS/RHEL 7.x and 8.x Apache HTTP Server version 2.4.6 tested (more versions supported)
Nginx versions 1.16 and 1.17 tested (more versions supported)
IBM HTTP Server versions 8.5 and 9 tested (more versions supported)
Apache Tomcat versions 8.5 and 9 tested (more versions supported)
Windows Microsoft Windows 10, 2012 R2 , 2016, 2019 Apache HTTP Server version 2.4.6 tested (more versions supported)
Microsoft IIS versions 7, 7.5, 8.0, 8.5, and 10 tested (more versions supported)
Nginx versions 1.16 and 1.17 tested (more versions supported)
IBM HTTP Server versions 8.5 and 9 tested (more versions supported)
Apache Tomcat versions 8.5 and 9 tested (more versions supported)

Sensor (agentless) automation for load balancers

Appliance Version
F5 BIG-IP LTM 12.1.0, 13.0.0, 13.1.1, 14.0.0, 14.1.2, 15.0.0, 15.1.0
Citrix Netscalar 11.1, 12, 12.1, 13
A10 2.7.2, 4.1.1, 5