Skip to main content

System and network requirements

Verify that your system and network meet the minimum requirements before you install the DigiCert ACME automation agent.

The agent must be installed on the same system as the automated TLS/SSL certificates.

System requirements

The ACME agent software runs on Linux and Windows systems, with the following requirements:

Red Hat Enterprise Linux 7.x, 8.x, and Ubuntu 20.04 or later

  • Root privileges

  • 64-bit version and US locale required

  • 2 GB RAM (4GB RAM recommended)

  • 2 GB free disk space (minimum)

Microsoft Windows 10, Server 2012 R2, 2016, 2019, and 2022

  • Run as administrator

  • 64-bit version

  • Microsoft .NET Framework 4.x

  • 2 GB RAM (4GB RAM recommended)

  • 2 GB free disk space (minimum)

Network requirements

The local ACME agent must be able to:

  • Connect outbound to HTTPS (port 443).

  • Connect outbound to the public IP address 216.168.244.42 (for acme.digicert.com and daas.digicert.com).

  • Resolve the fully qualified domain names (FQDNs) for the local web server, either via DNS or a local "hosts" file.

In addition, if the ACME agent will use a DigiCert sensor as proxy, make sure the default communication port is open on that sensor:

  • Communication port 8080 if the sensor version is 3.8.46 and older.

  • Communication port 48999 if the sensor version is 3.8.47 and newer.