Troubleshooting DigiCert ONE Clients
This section provides solutions to common issues you may encounter issues while using the DigiCert ONE Clients app.
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If you still need help once following these steps, contact DigiCert Support for further assistance.
Issue
When signing into the DigiCert ONE Clients app, no client tools appear.
Cause
This issue occurs if your DigiCert ONE user profile is missing the required user roles for the DigiCert ONE Clients app.
To view client tools, your profile must include:
This role is required for the app to retrieve account details, licensing information, and user permissions.
Any Trust Lifecycle Manager and, or Software Trust Manager user role
This role enables the app to display the correct client tools available to the user.
Solution
Check your user profile in DigiCert ONE to see if you have the necessary roles.
If you’re missing an Account Manager user role, contact your account administrator to update your user roles.
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Any Account Manager user role satisfies this requirement, even View only and Default user.
Issue
A specific client tool isn’t listed under My client tools in the DigiCert ONE Clients app.
Cause
Some client tools are restricted to certain operating systems. If a tool isn’t listed, it may not be compatible with your current operating system.
Solution
To verify that a client tool is hidden because it isn’t compatible with your operating system, follow this procedure:
Sign in to the DigiCert ONE Clients app.
On the My client tools dashboard, select Explore tools for other operating systems (bottom of the dashboard).
Find and download the required client tool.
Nota
Tools downloaded from this section aren’t installed or configured. Install and configure them manually on a compatible operating system.
Issue
An installed client tool doesn’t appear in the Installed section of the DigiCert ONE Clients app.
Cause
The DigiCert ONE Clients app can detect and display a client tool in the Installed section if:
The tool was downloaded from the DigiCert ONE Clients app.
The tool was installed using the legacy method and is stored in the expected (default) installation folder.
If the client tool doesn’t meet these conditions, the app may not recognize it as installed.
Solution
To ensure the client tool appears in the Installed section, consider reinstalling it through the DigiCert ONE Clients app for proper detection.
Issue
When using client certificate authentication to sign in to the DigiCert ONE Clients app, the incorrect certificate is automatically selected from your browser. This is a known limitation of version 1.0.1
and 1.1.0.
Cause
The DigiCert ONE Clients app supports client certificate authentication in Chrome, but doesn’t allow you to select from multiple certificates. It automatically selects the first certificate found in your browser’s certificate store.
Solution
Update your DigiCert ONE Clients to version 1.2.0
released on June 25, 20225 or later.
Open DigiCert ONE Clients.
Locate the profile icon (top-right).
Select Check for updates.
If an update is available, select Install.
Issue
You received an error message in the DigiCert ONE Clients app, but the message doesn’t explain the cause of the issue.
Cause
This may happen when there are multiple potential causes for the issue, and the app can’t determine the exact root problem at runtime.
Solution
On your computer, open the most recent log file in the logs folder to find detailed error messages and timestamps. You can also inspect the config.json file to verify whether your setup and permissions match what is expected for your account.
The DigiCert ONE Clients app logs can be found at this location:
Configuration logs can be found at this location:
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If you're unsure how to interpret the logs or config file, share them with your account administrator or DigiCert Support for further analysis.